Ultimate Amiga

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: +Edit.s fix submission  (Read 364 times)

Mia

  • A600
  • *
  • Karma: 1
  • Offline Offline
  • Posts: 101
  • Generic Amiga User
+Edit.s fix submission
« on: March 16, 2017, 10:37:09 PM »

Not sure if this is a known issue but my AMOSPro has always given an annoying flash of the screen when switching between Editor and Direct...

fixed by stopping the copper refresh on each switch in the file +Edit.s - commenting out all 12 occurances of:

Code: [Select]
bsr   EdReCopto
Code: [Select]
;bsr   EdReCop
basically the copper is not refreshed each switch - not sure what the full effect of this is yet but it's much nicer, I didn't like the flashes.

Edit:
Direct mode window doesn't refresh during resize and move, so uncomment in the subroutines

Code: [Select]
Ed_Ligne
Esc_MEcran
Edt_New
back to
Code: [Select]
bsr   EdReCop
« Last Edit: March 16, 2017, 11:09:24 PM by Mia »
Logged

Lonewolf10

  • AMOS Extensions Developer --------------------
  • AMOS Dev
  • A2000
  • *****
  • Karma: 3
  • Offline Offline
  • Posts: 597
    • http://www.aliensrcooluk.com
Re: +Edit.s fix submission
« Reply #1 on: March 17, 2017, 08:01:21 PM »

Not sure if this is a known issue but my AMOSPro has always given an annoying flash of the screen when switching between Editor and Direct...

It's not something I recall seeing, but my coding is all done under emulation on my laptop right now as both my Amiga 600s are down :(
Logged
Pages: [1]   Go Up